Author Topic: Can you guys make a video that show how to set up TENKOKU - Dynamic Sky  (Read 2209 times)

RushIsland

  • Newbie
  • *
  • Posts: 12
    • View Profile

Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1609
    • View Profile
    • Tanuki Digital
Yes, one is in the works actually as I've had a few requests for this already.  In the meantime I'll try and answer any questions you have here ASAP.  :)

RushIsland

  • Newbie
  • *
  • Posts: 12
    • View Profile
Can we talk on Skype or something i just so lost and i want to film the trailer for my game and i cant do it without your amazing tool >:

jf3000

  • Jr. Member
  • **
  • Posts: 97
    • View Profile
Following the instructions is quite easy

I. ADD IMAGE EFFECTS
If you don’t already have the Standard Unity Image Effects imported in your project then you need to import them by going to “ASSETS -> Import Package-> Effects...” in the Unity Menu.

Once they’re done importing, go to your scene camera object, and add one Sun Shaft image effect component to the camera.  Tenkoku automatically uses this sunShaft component for sun rendering effects.  If you don’t want sun shafts in Tenkoku then you can skip this step and not add it to your camera.

II. IMPORT TENKOKU FILES INTO YOUR PROJCT
Go to: “Assets -> Import Package -> Custom Package...” in the Unity Menu and select the
“tenkoku_dynamicsky_ver1.x.unitypackage” file. This will open an import dialog box. Click the
import button and all the Tenkoku files will be imported into your project list.

III. ADD LAYERS TO YOUR PROJECT
Go to: “EDIT -> Project Settings -> Tags and Layers...” in the Unity Menu and add 2 new layers to the list, one called “sky” and one called “moon”.

IV. ADD THE TENKOKU MODULE TO YOUR SCENE
1) Drag the Tenkoku DynamicSky prefab located in the “/PREFABS” folder into your scene list.
2) If it isn’t set already, make sure to set the Tenkoku DynamicSky’s position in the transform settings to 0,0,0
3) Under the Configuration tab change the “Sky Layer” and “Moon Layer” settings to the layers you set in Step 3.
4) Drag the main camera object you use in your scene onto the Main Camera slot.

Following these steps and also reading this section and disabling a few options for now will get the look you're after.

Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1609
    • View Profile
    • Tanuki Digital
Also the documentation PDF has some pictures of the setup which might help...
http://www.tanukidigital.com/tenkoku/documentation/


RushIsland

  • Newbie
  • *
  • Posts: 12
    • View Profile
Hey sir i did all what you said me to do and this is what i end up wait ):
Link to my pic:http://postimg.org/image/s75mbm9zh/

Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1609
    • View Profile
    • Tanuki Digital
This looks like the problem jf3000 was having... it's likely having to do with a bug in the camera render/tracking.  try this..
http://tanukidigital.com/forum/index.php?topic=547.msg1475#msg1475

RushIsland

  • Newbie
  • *
  • Posts: 12
    • View Profile
ok i will try it  :)

jf3000

  • Jr. Member
  • **
  • Posts: 97
    • View Profile
Its really simple after adding those 2 layers.

1. Drop module into scene, set to 0,0,0
2. Open FogSphere and untick Mesh Renderer
3. Open SkySphereSun then Sun and untick Lens Flare

Press Play

Works like a charm.