Author Topic: Cant Scale Water Properly  (Read 3718 times)

judah4

  • Newbie
  • *
  • Posts: 2
    • View Profile
Cant Scale Water Properly
« on: September 30, 2013, 01:56:38 AM »
Hi, Im trying to increase the area the water covers to at least 36k by 36k units and it is not working properly. I tried increasing the scale size, tiling the water meshes, adjust the master scale in the shader, or follow character position but nothing make the water look right and is a serious problem for me.  I really need a way to fix this or suimono is pretty much useless for me

Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1594
    • View Profile
    • Tanuki Digital
Re: Cant Scale Water Properly
« Reply #1 on: September 30, 2013, 03:43:30 AM »
Hi Judah4,

the water_preset component may be interfering with your scale settings... try the following and let me know how it works for you...

1) disable the water_presets component on your water surface object.
2) on the shader attributes set the Master Scale to around 70
3) set the Refraction Strength to 0.2
4) set the Refraction Speed to 0.01
5) set the Animation Speed to 0.25
6) change the HeightMap tiling to x20 y16
7) change the HeightMap2 tiling to x100 y100

this should give you a beter approximation of the normal scale, even at 36000 x 36000.
Let me know how this works for you or if you still have scale problems.

-Justin

judah4

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Cant Scale Water Properly
« Reply #2 on: September 30, 2013, 11:05:31 AM »
Thank you, this is so much better. Is there anyway improve framerate? it will probably be fine on my home computer but it drops the framerate on my laptop to about 45 fps.

Thank you so much for the help

Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1594
    • View Profile
    • Tanuki Digital
Re: Cant Scale Water Properly
« Reply #3 on: September 30, 2013, 12:09:27 PM »
The biggest factor to framerate drop with Suimono is typically the dynamic reflection generation, as it renders your entire viewable scene a second time.  You can adjust these parameters on the water_reflectionMirror component somewhat to increase speed... such as the using a lower resolution or rendering fewer in-game layers.  Or you can disable this component altogether, and you should see a speed boost.

If you disable the dynamic reflections you can use a pre-rendered cubemap for your scene instead which usually goes a long way to improving the visuals while keeping a balance of performance.

DonGray

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Cant Scale Water Properly
« Reply #4 on: July 26, 2014, 05:49:32 AM »
"1) disable the water_presets component on your water surface object."

How is this done?

Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1594
    • View Profile
    • Tanuki Digital
Re: Cant Scale Water Properly
« Reply #5 on: July 27, 2014, 09:40:25 AM »
Hi Don,
This is only possible with the 1.4x version of Suimono.  are you using the 2.0 beta?