Author Topic: Surface moves when I hit play  (Read 52 times)

akent

  • Newbie
  • *
  • Posts: 3
    • View Profile
Surface moves when I hit play
« on: November 09, 2020, 12:36:33 AM »
I may have adjusted some parameter, but cannot work out what it is. In editing mode I can see the water ("SUIMONO_Surface") at one location, nicely lined up with a pond behind a house. When I hit "Play", the water moves so it no longer is lined up with the indented area for the pond. I hit stop, and it returns to where it was supposed to be.

I have set the "presets" to "none" to stop it setting things back to the preset whenever I play (that was confusing for a while! lol!). I also set the "Shoreline Height" to zero because it looked like the water was curving upwards at the edge of the surface, which would make it overflow the pond at the edges of the surface. Setting height to zero seemed to stop that effect.

See attachments for screenshots... (Oh, had to delete the attachment because it said "upload area is not writable". Oh, it would not let me post as it thinks I already have. Umm, copying into a new post - sorry if a duplicate - I cannot see my old post in the forums.)

I can delete the water and start again in needed. Trying to work out the best way to get water in the pond. (Then next challenge is to get a creek to feed into and out of the pond to be more realistic.)

akent

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Surface moves when I hit play
« Reply #1 on: November 09, 2020, 12:49:44 AM »

Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1685
    • View Profile
    • Tanuki Digital
Re: Surface moves when I hit play
« Reply #2 on: November 09, 2020, 09:19:09 AM »
Hi Akent,

It's possible the internal surface objects moved or scaled as you were placing the water surface...?  Take a look at the 3 objects under your Suimono_Surface object, and make sure their position is set to 0,0,0... Also make sure the 'Surface Type' setting is set to "3d waves" to prevent any possible auto-positioning from the infinite ocean setting?

akent

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Surface moves when I hit play
« Reply #3 on: November 12, 2020, 12:16:08 AM »
Not sure how it happened, but yes - the Scale of a child had been set to 1.1 somehow. Setting that back to 1 fixed it.
Thanks!