Author Topic: Depth|ShadowMap RenderTexture warning  (Read 68 times)

asims

  • Newbie
  • *
  • Posts: 5
    • View Profile
Depth|ShadowMap RenderTexture warning
« on: November 14, 2018, 03:38:33 PM »
Hello I am using Tenkoku 1.1.7b on Unity 2018.2.15f1 (64Bit). In these days am using Prograssive Ligthmapping for my scenes.
The tenkkoku given and warning ( 999+ ) runtime. Warning message below.

RenderTexture.Create: Depth|ShadowMap RenderTexture requested without a depth buffer. Changing to a 16 bit depth buffer.

Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1609
    • View Profile
    • Tanuki Digital
Re: Depth|ShadowMap RenderTexture warning
« Reply #1 on: November 14, 2018, 05:12:46 PM »
Is that the full error message?  Are their any code pointers that show where this is originating from?

asims

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Depth|ShadowMap RenderTexture warning
« Reply #2 on: November 15, 2018, 05:04:37 AM »
Full Message  : RenderTexture.Create: Depth|ShadowMap RenderTexture requested without a depth buffer. Changing to a 16 bit depth buffer.

Screen Shoot is here   :    https://ibb.co/iaXjN0


Warning gone when i disable Tenkoku Dynamic Sky System. Its not refer code.

asims

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Depth|ShadowMap RenderTexture warning
« Reply #3 on: November 20, 2018, 12:12:43 PM »
still waiting help :)

Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1609
    • View Profile
    • Tanuki Digital
Re: Depth|ShadowMap RenderTexture warning
« Reply #4 on: November 21, 2018, 11:32:33 AM »
Hi asims, sorry for the delay.  I've tested in 2018.2.15 and cannot reproduce the problem... because of that it's hard for me to say where the problem is 100%.  BUT if I were to guess I would suggest opening the Scripts/TenkokuModule.cs file and making a code edit...

Around line 780 you'll see this line initiating a rendertexture:
_particleDensityLUT = new RenderTexture(1024, 1024, 0, RenderTextureFormat.RGFloat, RenderTextureReadWrite.Linear);

Ypu can try replacing the "0" with "16" like so...
_particleDensityLUT = new RenderTexture(1024, 1024, 16, RenderTextureFormat.RGFloat, RenderTextureReadWrite.Linear);

Then saving, going back to the unity editor and run your scene again.  I'd be interested to know if this makes any difference on your end?

asims

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Depth|ShadowMap RenderTexture warning
« Reply #5 on: November 29, 2018, 03:15:23 PM »
nothing changed. I also searching into code


Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1609
    • View Profile
    • Tanuki Digital
Re: Depth|ShadowMap RenderTexture warning
« Reply #6 on: November 29, 2018, 05:48:27 PM »
Another thing you can try is to go to the Tenkoku/Textures folder and change the 'renderTex_sky' and 'renderTex_skyFog' textures so that the 'Depth Buffer' setting is set to 16 bit.  Other than these I'm not aware of what other rendertextures the error would be referring to.

asims

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Depth|ShadowMap RenderTexture warning
« Reply #7 on: December 03, 2018, 07:58:45 AM »
it solves thank you  ;D ;D

Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1609
    • View Profile
    • Tanuki Digital
Re: Depth|ShadowMap RenderTexture warning
« Reply #8 on: December 03, 2018, 04:02:40 PM »
YAY!  ;D