Author Topic: Flickering water  (Read 624 times)

twbd

  • Newbie
  • *
  • Posts: 11
    • View Profile
Flickering water
« on: January 12, 2018, 10:20:37 AM »
hey guys, thanks for this beautiful water.

I have an  issue with flickering water https://gyazo.com/0181c4fe7621d8d560dffdc22e6dc76e

I'm not sure what i'm doing wrong but i have just launched demo project.

<aybe problem in that i use deffered rendering?

Thanks.

Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1587
    • View Profile
    • Tanuki Digital
Re: Flickering water
« Reply #1 on: January 12, 2018, 02:22:46 PM »
Deferred should not be a problem... it SHOULD work perfectly fine in forward or deferred.
Is this just the demo project with no changes?  Perhaps there's a project-wide setting that is affecting this... hmmm.  Does the buouyancy demo also have similar problem?

twbd

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Flickering water
« Reply #2 on: January 20, 2018, 12:09:03 PM »
Hi.

yes it was a demo. Here i have created clean project included prefabs Surface and Module and my camera. Here what i get.

https://gyazo.com/a42c184f1e747972ede81f5e1ab4845d

please nootice that i use 5 cameras at once. One parent object and 5 cameras included in it.

I'm not sure why is it flickering.

Can it be a problem thati'm using Directx11 only? Without Auto Graphic API?
« Last Edit: January 20, 2018, 12:40:43 PM by twbd »

Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1587
    • View Profile
    • Tanuki Digital
Re: Flickering water
« Reply #3 on: January 20, 2018, 07:13:00 PM »
dx11 shouldn't matter, actually it's preferred.  The flickering could be due possibly to camera tracking getting confused.  MAke sure only the main/top camera has the 'MainCamera' tag, and that all the others are marked as 'untagged'.  Then also make sure 'auto' is selected in the camera mode on the Suimono Module...?

twbd

  • Newbie
  • *
  • Posts: 11
    • View Profile
Re: Flickering water
« Reply #4 on: January 21, 2018, 07:50:06 AM »
Nope. the same problem. it is flickering the same. When i create clean project and insert my 3 cams with script PanoCam (that creates 3 cameras) i see reflection problems like this https://gyazo.com/f54e9cd2b36e6d33beda8c214b0dcb2f

DamianT

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Flickering water
« Reply #5 on: February 15, 2018, 06:26:04 PM »
I've had this issue myself, but only when the Unity Performance setting is set to "Fastest".

However,  I have not been able to track down the exact cause.  It does suggest that it is a project setting though.

Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1587
    • View Profile
    • Tanuki Digital
Re: Flickering water
« Reply #6 on: February 16, 2018, 11:45:29 AM »
Thanks Damian,
I did some tests here with the Fastest quality setting and indeed my water goes completely haywire, similar tot he first link in this thread.  Seems to be directly related to shadows being disabled during at that quality level.  The same thing happens even if I'm on the best quality level if I disable shadows on the main scene directional light.  I'm adding this to the bug list.