Author Topic: unity 5.6.1 problem  (Read 312 times)

Darkmonk

  • Newbie
  • *
  • Posts: 9
    • View Profile
unity 5.6.1 problem
« on: June 19, 2017, 09:19:25 AM »
Hi,

I recently had to upgrade my project to Unity 5.6.1f now when i create a build the scene does not look correct, the lighting on all my trees and rocks placed on the terrain get very bright, the only warning that appears is
- "RenderTexture.Create: Depth|ShadowMap RenderTexture requested without a depth buffer. Changing to a 16 bit depth buffer."

This only happens when using defered rending and did not happen when i was using Unity version 5.5.2. so it is new to the latest version of unity.
I am currently using Tenkoku version 1.1.5

Any advice would be very helpful as this is for a client and I really need to get this sorted quickly :(
Thanks,

Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1512
    • View Profile
    • Tanuki Digital
Re: unity 5.6.1 problem
« Reply #1 on: June 19, 2017, 11:54:06 PM »
Hi Darkmonk,
I'm not sure if the warning message in your build log would necessarily contribute to your overbrightening problem.  I did some tests and I also receive the same warning when I check my build log, both in Tenkoku 1.1.5 and 1.1.5e... I don't have this issue with the upcoming 1.1.6 update.  But in all these versions I didn't see any difference between editor rendering and build rendering.

Is it possible to post a screenshot showing the difference between your editor view and build view?  Seeing a comparison might help me determine what's happening.

Darkmonk

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: unity 5.6.1 problem
« Reply #2 on: June 20, 2017, 02:18:01 AM »
hi thanks for getting back to me so quickly :)

attached is an image showing the 2 different states.
I have managed to recreate the effect in the scene view so i can show the changes exactly.
The overbrightening only affects objects that have been placed as trees on the terrain, so in the image you can see the trees and the small rocks on the ground all get brighter, these are all placed as trees on the terrain.

Not sure if this would make a difference but i am also using the Relief Terrain Pack on my terrain. https://www.assetstore.unity3d.com/en/#!/content/5664



« Last Edit: June 20, 2017, 03:02:33 AM by Darkmonk »

Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1512
    • View Profile
    • Tanuki Digital
Re: unity 5.6.1 problem
« Reply #3 on: June 20, 2017, 09:00:00 AM »
From your screenshot, it seems like it's occurring on the rock objects as well as the trees.  Or basically anything that isn't the terrain/grass?  It almost looks like the ambient reflection probe contribution... but I'm not sure why that would change between editor and build.

You can try turning off the Tenkoku reflection probe, under the configuration settings section, as it looks like you have very little ambient reflection conribution anyway(?), it would be interesting to see if this would indeed keep things consistent from editor to build.

Also, the Tenkoku 1.1.6 update is almost ready and perhaps might work better for you in this case (I don't get the rendertexture warning message in 1.1.6).  If you would like to try a preview version of 1.1.6, I can post a direct link of my current updates for you to download and try on your end. Email me your invoice number at konnichiwa@tanukidigital.com (Your invoice number is 9-digits and should start with 302 or 303.  If it doesn't appear on your invoice, you can check it on the Asset Store by logging into your account and checking the credit card/paypal section)

Darkmonk

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: unity 5.6.1 problem
« Reply #4 on: June 20, 2017, 02:08:25 PM »
Hi,

yeah the rock small prefabs are being applied to the terrain as if they were trees so I tihnk this is why they are also having the problem.
I tried turning off the reflection probe but it made no difference :(

Will send you an Email now with my invoice details

Darkmonk

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: unity 5.6.1 problem
« Reply #5 on: June 21, 2017, 07:35:08 AM »
Hi,

Ive just tried your new version 1.1.6 and i still get the same warning message and its not changed anything :(
I did a test import into a completly clean project and opened your demo scene _Tenkoku_Demo_Scene and changed your camera to Deferred then pressed play, this brings up the warning message
RenderTexture.Create: Depth|ShadowMap RenderTexture requested without a depth buffer. Changing to a 16 bit depth buffer.

Ill do some more research to see if i can get you some more info.

simonmc

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: unity 5.6.1 problem
« Reply #6 on: June 22, 2017, 12:22:32 AM »
Hi guys,

I encountered something similar and the issue is the reflection probe, as Chingwa assumed. Enabling reflection probe and making sure Update FPS wasn't zero fixed the visual aftifacts for me.

I do still get that warning, but it doesn't appear to affect anything.

Darkmonk

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: unity 5.6.1 problem
« Reply #7 on: June 22, 2017, 04:13:48 AM »
Interesting, ill have another look into the reflection probes then and see how it affects things, thanks Simonmc always good to hear from somebody else who has experience a similar issue.

Darkmonk

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: unity 5.6.1 problem
« Reply #8 on: June 26, 2017, 08:28:26 AM »
ok, been playing around with the reflection probe stuff and it does not seem to make any difference :( ive been changing everything i possibly could to try and make it work correctly but I cant seem to fix this at all :(

Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1512
    • View Profile
    • Tanuki Digital
Re: unity 5.6.1 problem
« Reply #9 on: June 26, 2017, 12:21:03 PM »
Hi Darkmonk,

Sorry to hear you're still running into trouble!  I've done tests here on my end in 5.6.1 but so far have not been able to recreate this problem.  Have you considered upgrading to Unity 5.6.2?  I read through the upgrade notes and didn't notice anything specifically about reflection probes, but perhaps some other changes they've made might help this situation.

You also might consider switching the ambient mode to 'color' or 'gradient' in the Tenkoku configuration tab.  It's unclear to me if they would be directly related to your problem, but it's worth a shot.  These modes use solid color for ambient instead of sampling the scene/reflection probe.

Darkmonk

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: unity 5.6.1 problem
« Reply #10 on: June 27, 2017, 08:30:26 AM »
not sure if 5.6.2 will fix it but i could maybe try, depends on if my client is going to upgrade. I told them not to upgrade to 5.6 and they did it anyway and now things dont work :(
Changing the ambient mode to 'color' or 'Gradient' does not affect the problem area.

I believe the problem is not the reflection probe but actually the light probes, all trees and rocks placed on the terrain using the place trees section in the terrain settings are using light probes for indirect lighting, if i disable light probes on the trees then the issue does not occur, this means though that i lose out on the indirect lighting on these props which is not great.
Any idea what could cause the issue with the light probes ?

Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1512
    • View Profile
    • Tanuki Digital
Re: unity 5.6.1 problem
« Reply #11 on: June 27, 2017, 10:56:58 AM »
I'm not sure about the light probes.  It's possible the probes are not updating properly in the build mode, so they are getting light info during daytime and not updating for darker lighting situations.  Is there a way to force update the probes or are they baked?

Darkmonk

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: unity 5.6.1 problem
« Reply #12 on: June 28, 2017, 07:24:11 AM »
ok, im 100% sure its the lightprobes, ive attached an image showing a before and after of the ligthprobes. Basically if i load the scene it looks correct, after pressing the play button it looks ok when im playing in editor but after i stop playing the lightprobes change to be super bright, this is exactly how it looks when i make a build. if i play in the editor again it looks fine, very strange.
It seems to be the indirect light that is getting blown out of proportion.

the probes get baked when i do a light build but I am using realtime global illuminaion in the scene so its only baking the GI.

I also tried unity 5.6.2 today but it was exactly the same :(


Darkmonk

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: unity 5.6.1 problem
« Reply #13 on: July 11, 2017, 03:40:11 AM »
Hi,

Wanted to let you know that i updated to the latest version you have on asset store and it seems to have fixed the issue in the build, I can still re-create the problem in the editor which is strange but our build is currently lighting correctly now which is cool :)

I have noticed slightly less fps than before though so wanted to know if there was anything different that has been added that could be affecting performance ?
Before the update i was getting a steady 60 fps but now its dipping under 60 a little bit. I still need to optimise my scene so its probably not a big issue for me but if there was anything obvious you could think of to tweak that might help then i would be greatful for any ideas you had.

Thanks

Chingwa

  • Administrator
  • Hero Member
  • *****
  • Posts: 1512
    • View Profile
    • Tanuki Digital
Re: unity 5.6.1 problem
« Reply #14 on: July 11, 2017, 08:05:51 AM »
Hi DArkmonk,

I'm glad the new update has helped!

As far as performance goes, the only addition that I can think of that might cause increased performance lag is the inclusion of a new Light object called 'LIGHT_NightFill'.  This object lights the scene from dusk to dawn and gives a constant light source in order to improve night rendering visibility.  During the day this object should be off.  Is your FPS drop constant during both day and night?

Another culprit may be just some of the default settings in Tenkoku.  First double check your Reflection Probe Update FPS setting and adjust this to be lower/slower to suit your scene.  Also the LIGHT_NightSky object has been set to soft shadows by default, this might be contributing a small amount to your drop (but again, this would only be at night).